You are here: Home / News & Events / News / Deprecated Python modules will be renamed next week

Deprecated Python modules will be renamed next week

Nov 12, 2021

Dear users,

Deprecated Python environments

Since several years, we are offering Python environments on Mistral. Many of them are not updated any more and should not be used for new development. However, older scripts may rely on these environments and the versions of their installed packages.

To discourage their use while still keeping them available, we will rename some modules next Monday, November 15, 2021, from

anaconda2/bleeding_edge
anaconda3/bleeding_edge
python/2.7-ve0
python/2.7.12
python/3.5.2

to

anaconda2/.bleeding_edge
anaconda3/.bleeding_edge
python/.2.7-ve0
python/.2.7.12
python/.3.5.2

Notice the dot in the module name. The renamed modules will not be listed with module avail but they can still be loaded and show the same behavior as before, e.g.

module load anaconda3/.bleeding_edge

Recommended Python environments

For new developments, we recommend using only the Python environment

python3/unstable

In this environment we will still install new packages if available. However, since many of the most recent conda packages do not support Mistral's RHEL6 operating system, you may have to settle for a slightly older version.

Frozen environments which only receive security updates continue to exist for legacy scripts.

python3/2020.02-gcc-9.1.0
python3/2020.09-gcc-9.1.0

Best regards,
DKRZ

Document Actions

Filed under: