You are here: Home / Help / FAQ / Mistral / Which MPI library and compiler should I use?

Which MPI library and compiler should I use?

For model simulations in production mode, the recommended combination is to

  1. Choose an Intel compiler version that has been validated to work with your model. Lacking a verified version, just use the most recent version (module intel/18.0.4 at the time of this writing) and validate that yourself.
  2. Use Open MPI 2.0.2p2 with HPCX toolkit (module openmpi/2.0.2p2_hpcx-intel14). The '-intel14' suffix indicates the the Open MPI library has been built for Intel 14, but it is compatible with all newer Intel compiler versions. For some models or single node jobs, it might make sense to use Intel MPI (module intelmpi/2018.5.288) because it is sometimes faster. Please notify us, in case that proves true for you.
  3. Do not forget to consult the recommended environment settings and adjust your run script accordingly. Without these settings applications can run unexpectedly slowly.

 

Document Actions